ForeSight Tutorial
CHaMP GIS Training 2013

Introduction
Survey data from the Total Station (.job and .raw files) are not immediately readable in ArcGIS (software used for most of the topographic and RBT processing). ForeSight is software used for processing raw survey files used to convert raw total station data into a GIS-readable format. You must open .job and/or .raw files in ForeSight before continuing to process topographic data in GIS.

[image: https://encrypted-tbn2.google.com/images?q=tbn:ANd9GcSeJZLj3Fry2qNB4aSCu6iYX02cGRO3uT-0hfs43oGQYPBRLi3hhQ]NOTE: Make sure to connect the ForeSight Hardware Key (i.e. USB dongle) before starting ForeSight. Do not remove the Hardware Key while ForeSight is open. 

Objectives
In this tutorial, you will learn how to:
· Import Total Station Survey Data
· Visualize and Explore the Data
· Identify and Uncross Breaklines
· Change (incorrect) Description Codes
· Export a DXF file
Required Datasets
ForeSight_Tutorial.job
ForeSight_Tutorial.raw
Field Crew Notes 
The following is an excerpt from the survey crew’s field notes that provide information on repairs that need to be made to the data in this tutorial:
1. Pt 10 and Pt 11: Remove points from the survey
2. Pt 175:  There was an error in the elevation, it should be: 1405.621 m 
3. Pt 179: There was an error in the elevation, it should be:  1405.346 m 
4. Pt 427: There was an error in the description, it should be:  tb
Instructions
[bookmark: _Toc326237020][bookmark: _Toc357767004]Start New ForeSight Project
A ForeSight Project is similar to an ArcGIS Map Document. It is used to display edits and layout changes made in ForeSight, but does not actually contain the point and line data (this is in the .job file).
1. All Files used in this tutorial are found in:  …\CHaMP_GIS_Tutorials\ForeSight
2. Open ForeSight (From the Desktop or Start menu -> All Programs/Spectra Precision/ForeSight)
3. Use the Wizard to Create a new Project (Do not use File/Open):
[image: ]
4. Set the Data Source to TDS JOB and RAW files (from Survey Pro CE). Click Next.
5. Select ForeSight_Tutorial.job  as the JOB file for the survey. The RAW file should automatically populate when the .job file is selected. Ignore Control file input (i.e. should remain blank). Click Next.
Enter the project name: SiteName_YYYYMMDD. The project folder should be set to the same folder where your data is located (i.e. …\Tutorials\ForeSight). Ignore Project Template. Click Next.
Note: 
ForeSight will always default to the same location for the Project folder. You will need to change this every time you start a new project.
6. Click Finish. You may uncheck the New Project Task List.
7. Your survey should now be displayed on the screen.
Visualizing and Exploring the Data
[bookmark: _Toc357767006]Map View
Map view provides a 2-D view of the survey area.
· To change the color of the background, points or lines:
· Open the File->User Options and select the item in the Graphics box you wish to update. Choose a new color.
· To temporarily hide the point Descriptions/Point Numbers:
· Open View and select Non Plotting Point Labels to uncheck it. Select Non Plotting Point Labels again to return the point description codes and numbers.
· You can use the scroll wheel on the mouse to zoom in and out of the map.
· Use the Zoom Extent button to view the entire survey area.[image: ]
[bookmark: _Toc357767008]Terrain View
The Terrain view provides a 3D representation of the survey surface. This is helpful for getting a feel of the 3D aspects of the data, but is not the actual surface that will be used in GIS. Go to View -> Surface.
· To zoom in and out in Surface View, click both mouse buttons and move mouse towards you to zoom out and away from you to zoom in.
· Left mouse button pivots the surface.
· Right mouse button moves it up or down on the screen.
· You can change the color, shading and vertical exaggeration of the surface in the SurfaceView Control Center.
Tutorial Data Check
Does the 3D preview look like a topographic survey, or does the survey look distorted? A ‘stretched’ surface can be an indication of a potential problem in the data. Make a note of this and move on – we will pinpoint and repair this problem later in the tutorial.
· Return to the Map/Plan View by clicking the Plan View button
[image: ]
Editing Tasks in ForeSight
Uncrossing A Set of Crossed Breaklines
Scan the survey map and examine the linework for any crossed hard breaklines. 
The following is an example of a breakline to fix at Point 276.
1. Click View -> Zoom -> Zoom to Point. Enter “276” in the popup box and Click the Zoom button.
[image: ]
2. Notice how this point is part of a “left edge of water (lw)” Line. The position of point “276” causes the line to cross a nearby “Top of Bank (tb)” line. Since it is only 3 cm away from the line, we can move the point to the other side of the line to uncross these breaklines.
3. Go to Map -> Edit Points.
4. Click the Edit Existing button (Note the boarder that appears around the button that indicates the button is active).
5. Click on the point “276” to select it.
TIP
Use the Escape key to release selected points or lines
6. Under the Location tab, check the Change Location of this Point box.
7. Copy the value in the Elevation Box (Highlight the value and press control+C).
8. Click in the Northing Box. The Coordinate boxes will become ACTIVE.
9. Now click on the map at a new location for the point (the other side of the line, not too far from its current location). The coordinate boxes will update their values accordingly.
10. Paste the Elevation value back into the Elevation Box.
11. Click Apply to move the point. 
Any linework attached to the point will move after the map is refreshed.  You can refresh the screen using the Pan tool or the Zoom tool.   
[image: ]
IMPORTANT – Moving Survey Points
In general, moving survey points is discouraged, as they represent a sampled location of the topography, however, in the case where a line vertex crosses a breakline (within ~5cm), it is acceptable to move the point to the correct side of the breakline. 
In all other cases, you should delete the point from the survey, as it should be considered an erroneous point.
[bookmark: _Toc357767012]Deleting Points (and Line Vertices)
From the field crew’s notes, we need to delete points “10” and “11”. 
1. Zoom to Point “10” (refer to step 1 in the previous section).
2. Go to Edit -> Delete Objects.  
3. Click the Select Objects to Delete button.
4. Click on points “10” and “11”.  They will change color.
5. Click the Delete Button to delete these features.
TIP
  To undelete a point or undo an edit:  Select Edit -> Undo
[bookmark: _Toc357767014]Check/Change Point Elevation Values and Description codes
1. Click on the Coordinate View button.   
[image: ]
A table listing all of the survey points will open.
2. Click on the Elevation Column to sort numerically.  Click a second time to reverse the sort order.
a. Scan through the list of elevation values.  
b. Make sure that all elevations are within a reasonable range of values. 
c. Make sure there are not any negative, zero (0.000) or null values present. Delete these points from the survey or update with corrected values. (Hint: check the Field Notes Section at the beginning of this tutorial).
d. If you need to change any other Elevation Value, double click on the value in the spreadsheet. A popup box will appear. Change the values and click ok to save the change.
3. Now click on the Description column to sort alphabetically.
a. Scan through the list of code values.  
b. Make sure that all codes conform to the current version of the protocol. 
c. To change a Description Code, Double Click on the value in the spreadsheet. A popup box will appear. Change the values and click ok to save the change.
[bookmark: _Toc357767020]Add a New Line (Draw Lines Method) 
Lines are an important part of the topographic data. They are used to represent breaks in grade and have a significant influence in the topographic surfaces generated during the GIS processing. It is generally easier to add or modify 3-D Linework in ForeSight than in ArcGIS. Keep in mind, when you are creating lines, you are only doing so by connecting existing survey points. You cannot create new line vertices from scratch. 
IMPORTANT
The creation of new lines MUST be done in on the Total Station or in ForeSight.  If lines are incorrect when displaying the survey in ArcGIS, go back to the survey data in Foresight, make the appropriate corrections, and reimport into ArcGIS.
It is highly recommended to collect line features in the field whenever possible, since this is the best place to make judgments on where lines should go.

In this example we will connect a set of points to form a new line.
1. Zoom to Point ‘573”. 
2. Go to Map menu at top of screen and select Add sets/Draw lines. 
3. With Draw Lines window open, use mouse to select points “573”, “574”, “575”, and “576” (description code “bl”) on the display screen.  
a. You will see that when a point is selected, a line will be attached to the mouse indicator.
b. Click on desired points to connect lines in succession to create a polyline.
4. Click the Close button at the bottom to finalize the line.
[bookmark: _Toc357767023]Connecting Line Segments
In this example we will connect two line sets to form a continuous line
1. Zoom to Point “461”.
2. Go to the Map menu and select Edit Sets/Lines. 
The line editing Edit Set window will open.  
3. Select the Add to End tab. Select the Edit Existing icon and move mouse over the “lw” line and select it. 
4. In the Append to point:  box there are two point number options of where to append a line to the one you just highlighted.  These point numbers represent each end of selected line.  
a. Make sure Select points to append: icon is selected and choose point “461”
b. Click on point “461”, then on point “450”.
5. Click Close to save the new line.

Repeat these steps for points “525” and “451” (a “tb” line).

[bookmark: _Toc357767024]Deleting Line Segments
This method is used to correct a line segment that has been connected to an incorrect point or as an alternative method for handling crossed breaklines:
1. Zoom to Point 380.
2. Go to the Map menu and select Edit Sets/Lines. The line editing Edit Set window will open.  
3. Select the Break tab in the Edit Set window.  
4. Select the Edit Existing icon.
5. Use the mouse to select the “tb” line (attached to point 380).
6. Next, select the Break and delete segment: icon located under Choose location and type of break.
7. Move the mouse to line segment (between points 380 and 376) that needs to be deleted and click on it.  The line segment should be removed.
8. [bookmark: _Toc357767025]Click Close.     

Final Review
1. Look at the Terrain (Surface) View again to see how your changes and edits affect the topographic surface.
2. Click Recalculate Surface button to refresh the view.
3. Did the Surface View change from the first time you viewed the data?
4. You can also adjust the Vertical Exaggeration in the box on the left menu.  Adjust it up and down, then recalculate the surface and look at the differences.
5. Return to the Map View when you are finished reviewing your 3D surface.









Export the Data from ForeSight
[image: ]Once all point descriptions and lines have been edited in Foresight. Files will need to be exported for further editing and TIN/DEM creation in ArcGIS.
1. Select File  Export  AutoCAD (.DFX & .DWG)… 
2. The Export AutoCAD window will appear: 
3. Select DXF under AutoCAD File Type.  
4. Make sure that Export all is selected under Objects To Export. 
5. Leave all other default settings including Label AutoCAD points.
6. Click Export.
7. Export your data as “…\Tutorials\ForeSight\ ForeSight_Export.dxf”.

Save your project file and close ForeSight.  The survey data is now ready to be used in ArcGIS to create TINs and DEMs. You have completed the ForeSight Tutorial.


[bookmark: _GoBack]
image4.png
7o Gl 8] &e|




image5.png
Point:

Laper

Descipton

Zoom





image6.PNG




image7.png
& ForeSight 2.2.5 (DEMO MODE) - Plan View]

Fie E ntour Road _Adjustments
% | Export AutoCAD
D Fie Type

[

Evport DTM orly

 Help, press FL





image1.jpeg




image2.png
ggggggggggggggggg




image3.PNG
Blala





