
ForeSight Processing Guide 

CHaMP Field Season 2013 

Survey data from the Total Station (.job and .raw files) are not immediately readable in ArcGIS (software 

used for most of the topographic and RBT processing). ForeSight is CAD-style software used for 

processing raw survey files used to convert raw total station data into a GIS-readable format. You must 

open .job and/or .raw files in ForeSight before continuing to process topographic data in GIS. 

 

NOTE: Make sure to connect the ForeSight Hardware Key (i.e. USB dongle) 

before starting ForeSight. Do not remove the Hardware Key while ForeSight is 

open.  
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ForeSight Basics 

General CHaMP Workflow for ForeSight 
The general workflow used in CHaMP is as follows: 

1. Import Survey Data from Total Station (.job/.raw files). 
2. Preliminary Data Evaluation 

a. Shifts in Survey Data 
b. 3D Terrain/TIN 

3. Point/Object Editing 
a. Point XY and Z  
b. Description Codes 

4. Linework editing 
a. Auto Linework - used to create and edit sets of lines 
b. Edit Sets/Lines 

5. Export Survey Data (as DXF file) 

Start New ForeSight Project 
A ForeSight Project is similar to an ArcGIS Map Document. It is used to keep track of edits and layout 

changes made in ForeSight. 

1. Open ForeSight and use the Wizard to Create a new Project: 

 
2. Set the Data Source to TDS JOB and RAW files (from Survey Pro CE). Click Next. 

3. Select the .job file for the survey. The raw file should automatically populate when the .job file is 

selected. Ignore Control file (should remain blank). Click Next. 

4. Enter the project name: SiteName_YYYYMMDD. The project folder should be set to the Topo 

folder for the site visit. Ignore Project Template. Click Next. 

5. Click Finish. You may uncheck the New Project Task List (this does not apply for CHaMP Surveys). 

Your survey should now be displayed on the screen. 
 
 
 
 
 
 
 
 
 
 
 



Navigating Foresight 2.2.5 
ForeSight Window: 

 

Buttons and Tools: 

 

Map (Plan) View 

Map view provides a 2-D view of the survey area. 

 To change the color of the background, points or lines: 

o Open the File->User Options and select the Graphic type you wish to update the color. 

 To temporarily hide the point Descriptions/Point Numbers: 

o Open View and select Non Plotting Point Labels to uncheck it. Select select Non Plotting 

Point Labels again to return the point description codes and numbers. 

 You can use the scroll wheel on the mouse to zoom in and out of the map. 

 Use the Zoom Extent button to view the entire survey area. 

Map View/Surface 

View/Coordinate List Panel 

Navigator/ 

Options 

Panel 



Coordinate List View 

This view provides a spreadsheet list of the points and their attributes in the survey.  

 Clicking on a column heading will sort the list by the values in that column. Clicking on the 

column heading a second time will reverse the sorting of the list by the values in that column. 

Terrain View 

The Terrain view provides a 3D representation of the survey surface. This is helpful for getting a feel of 

the 3D aspects of the data, but is not the actual surface that will be used in GIS. 

 To zoom in and out in Surface View, click both mouse buttons and move mouse towards you to 

zoom out and away from you to zoom in. 

 Left mouse button pivots the surface. 

 Right mouse button moves it up or down on the screen. 

 You can change the color, shading and vertical exaggeration of the surface. 

  



Common Editing Tasks in ForeSight 

Point YX Locations 
If you find a point or line vertex that is in the incorrect location, you can move or delete the point. 

IMPORTANT – Moving Survey Points 

In general, moving survey points is discouraged, as they represent a sampled location of the 

topography, however, in the case where a line vertex crosses a breakline (within ~5cm), it is 

acceptable to move the point to the correct side of the breakline.  

In all other cases, you should delete the point from the survey, as it should be considered an 

erroneous point. 

Moving Points (and Line Vertices) 

1. Go to Map -> Edit Points. 

2. Click on the point you want to move. 

3. Under the Location tab, check the “Change Location of this Point” box. 

4. Copy the value in the Elevation Box (Highlight the value and press control+C). 

5. Click in the Northing Box. The Coordinate boxes will become “active”. 

6. Now click on a location on the map where you want to move the point. The coordinate boxes 

will update their values accordingly. 

7. Paste the Elevation value back into the Elevation Box. 

8. Click Apply to move the point. Any linework attached to the point will move after the map is 

refreshed. 

Deleting Points (and Line Vertices) 

1. Go to Edit -> Delete Objects… 

2. Click on the point(s) (or entire line) you want to delete. 

3. Click the Delete Button to delete the Features. 

Point Elevations 

Check/Change Point Elevation Values 

1. Click on the Coordinate View button 

2. Click on the Elevations Column to sort numerically. 

3. Scan through the list of elevation values.  Make sure that all elevations are within a reasonable 

range of values.  

a. Make sure there are not any negative, zero (0.000) or null values present. Delete these 

points from the survey 

b. To change an Elevation Value, double click on the value in the spreadsheet. A popup box 

will appear. Change the values and click ok to save the change. 

 



Point Descriptions 

Checking/Changing Point Descriptions in Coordinate List View 

4. Click on the Coordinate View button 

5. Click on the Description Column to sort alphabetically. 

6. Scan through the list of code values.  Make sure that all codes conform to the current version of 

the protocol.  

7. To change a Description Code, double click on the value in the spreadsheet. A popup box will 

appear. Change the values and click ok to save the change. 

Changing a Group of Point Descriptions 

To change the descriptions of multiple points that share a description, use this option.  
1. Click the Edit menu in the top left of screen  
2. Select Edit Objects.  
3. Check the box next to the Change descriptions of the points option shown (red circle) in the 

illustration below (Figure 1). 
4. To select which descriptions to edit, click the Select button next to the Select objects to edit 

icon. The next window will contain tabs which represent different methods of selecting which 
points are to be edited as illustrated below (Figure 2). 
 

 
 
 
 

Figure 1. Figure 2. 

Select points by description 

or point list 

 

Select points in the display 

screen 

 



5. In Figure 2, the Description tab is selected.  This tab is very useful if a number of the same codes 
were recorded incorrectly and thus every point with that code is mislabeled. To change the 
description of every point labeled with a specific description: 

- Click the drop down menu labeled Description and Select the desired description.  
- At bottom of window Click the Add button, this will select all points with the above 

description.  They will be highlighted yellow in display screen.  
- Click Close button at bottom of screen.  
- Once closed, the Edit Objects window will reappear as shown in Figure 1. In the field 

under the checked Change the description box, Enter in the new description and 
click Apply.  All selected point descriptions will be changed accordingly. 

Changing Point Descriptions by Specific Point(s) 

If there are specific points that need descriptions changed, use this 
option. 

1. Click the Edit menu in the top left of screen (Figure 3) 
2. Select Edit Objects.  
3. Click the Select by… Button. 
4. Click on the Point List Tab 
5. Input the point numbers separated by commas in the List of 

points: field  
o Click Add.  The points designated will be selected. 
o Click Close button at bottom of screen.  
o Once closed, the Edit Objects window will reappear as 

shown in Figure 1. In the field under the checked 
Change the description box, Enter in the new description 
and click Apply.  All selected point descriptions will be 
changed accordingly.   

6. One can also manually select individual points in the display 
screen by clicking the Select objects to edit icon at top of Edit 
Objects window (Figure 1). 

Adding New Lines 
Lines are an important part of the topographic data. They are used to represent breaks in grade and 

have a significant influence in the topographic surfaces generated during the GIS processing. It is 

generally easier to add or modify 3-D linework in ForeSight than in GIS.  

 

 

 

 

 

 

 

 

 

Figure 3. 



TIP: Isolating Points  

To more efficiently view points by descriptions in order to create/edit lines, it is helpful to isolate the 

points that are intended to be part of a new line or existing line.  

1)  Go to Edit and select Edit Objects. 
2)  Check the box next to Change the layer of the object(s) . 
3)  Click the Select button to open selection options. 
4) Select Description tab and input the desired description, click Add.  

All points matching that description should be highlighted. 
5)  Close Select By window and click on the Create new layer button 

(Figure 4).Name the layer based on the description of the selected 
points. 

6) Click Apply at the bottom of the Edit Objects window. 
7) Change the Active Layer to the layer you just created using the drop 

down menu on the layer toolbar (Figure 5). 
8) Click the Isolate Active Layer icon on the toolbar (Figure 5). 
 
Now the polyline can be created and edited without the other point types 
disrupting the view. 

 
 
 
 
 
 
 
 

 
In some cases, not all lines are collected as lines in the field.  Therefore it may be necessary to create 
new lines using Foresight.  Keep in mind, when you are creating lines, you are only doing so by 
connecting existing survey points. You cannot create new line vertices from scratch.  
 

IMPORTANT 
The creation of new lines MUST be done in on the Total Station or in Foresight.  If lines are incorrect 
when displaying the survey in ArcGIS, go back to the survey data in Foresight, make the appropriate 
corrections, and reimport into ArcGIS. 
It is highly recommended to collect line features in the field whenever possible, since this is the best 
place to make judgments on where lines should go. 

Draw Lines Method  

1. Go to Map menu at top of screen and select Add sets/Draw lines.  
2. With Draw Lines window open, use mouse to select points on the display screen.   

o You will see that when a point is selected, a line will be attached to the mouse indicator. 
o Click on desired points to connect lines in succession to create a polyline. 

3. Click the Close button at the bottom to finalize the line. 
 

Isolate Active Layer Active Layer 
Figure 5. 



List of Points Method 

New lines can also be created using a list of points. 

- In the Enter a list of points field, list your points in the proper succession you want 
your line to follow.  Points can either be entered as individual points (33, 34, 39), as 
a range of points (33-42) or a combination of both (33,39,40-42). 

- Click Create.  
 

TIP  
Always check to see that your line was drawn correctly after completing a step. ForeSight generally 
will draw the points by the order of the Points (by Point Number). You may need to edit or adjust the 
auto-linework. 

Edit Existing Lines 

Connecting Line Segments 

To connect two line sets to form a continuous line: 
1. Go to the Map menu and select Edit Sets/Lines. The line editing Edit Set window will open 

(Figure 6).  

 
2. Select the Add to End tab (Figure 6). Select the Edit Existing icon and move mouse over desired 

line and select it.  
3.  In the Append to point:  box there are two point number options of where to append a line to 

the one you just highlighted.  These point numbers represent each end of selected line.   
4. Make sure Select points to append: icon is selected and choose the point that represents the 

end of the line that needs to be appended to the highlighted line 
5. Click Close. 

Figure 6. 



Deleting Line Segments 

To correct a line segment that has been connected to an incorrect point in the field or when editing in 
Foresight: 

1. Go to the Map menu and select Edit Sets/Lines. The line editing Edit Set window will open 
(Figure 6).   

2. Select the Break tab in the Edit Set window (Figure 7).  

 
3. Select the Edit Existing icon. 
4. Use the mouse to select the line that needs editing. 
5. Next, select the Break and delete segment: icon located under Choose location and type of 

break. 
6. Move the mouse to line segment (between points) that needs to be deleted and click on it.  The 

line segment should be removed. 
7. Click Close.                 

  

Figure 7. 



Exporting Data from ForeSight 
Once all point descriptions and lines have been edited in Foresight. Files will need to be exported for 
further editing and TIN/DEM creation in ArcGIS. 
 
To export the Survey data:  

1. Select Edit  Export  AutoCAD (.DFX & .DWG)…  
2. The Export AutoCAD window will appear:  

 

 
 

3. Select DXF under AutoCAD File Type (Figure 8).   
4. Make sure that Export all is selected under Objects To Export.  
5. Leave all other default settings including Label AutoCAD points. 
6. Click Export. 
7. Save Project in the appropriate file location and name accordingly. 

 
The survey data is now ready to be used in ArcGIS to create TINs and DEMs.  



Advanced Tasks in ForeSight 
These tasks are not required for part of the general workflow and  

Repairing Alpha-Numeric Point Names in ForeSight 

Background 

Alphanumeric point names are an optional setting on the Total Station when collecting points during a 

survey. ForeSight, however, cannot generate points from raw data when alphanumeric points are used. 

It is best to avoid using alphanumeric point names when conducting surveys. 

This tutorial describes how to change invalid point names (i.e. Alphanumberic) to numbers in the .raw 

file using ForeSight.  

Steps 

1. Back up your original data files. 

2. Start a new project in ForeSight with your .job and .raw file (as normal). 

3. Click the Raw Data View button.  

4. Scroll through the entries until you find the entry where the problem point name was created. 

Example “bm3”: 

 
 

Figure 9. 

 

5. Double click on the entry (or entries) and change ForeSight Point to a new number (make sure it 

has not been previously used in the survey, i.e. 9999). 

 
Figure 10. 

Click Store. 

 



6. For Store:Point: entries, change the Point name to a new number (you can use the same 9999 

as before): 

 
Figure 11. 

Click Store. 

 

7. The changed values should be reflected in the entry log: 

 
  Figure 12. 

8. Click Tools / Generate Points from Raw Data. Uncheck the three boxes: 

 
Figure 13. 

Click View Report 

 



Note: If you get an error message, then you have not found all of the alphanumeric point names 

in the data. Go back to the raw data and make additional edits. 

 

9. Make sure the report reflects the changes you want to make: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 14. 

10. Click OK to close the report, and then click Generate. 

  

If you press 'Generate'...._____________________________________ 
Point 9999 will be added. 

 
Summary: 
  1 points will be added 
  0 points will be moved 

0 warnings 
1.End of Report 

 

If there are errors in the report, then go back to the raw data to make 

additional edits. 

 

Note: There might be some additional changes reflected in the report 

than move a point somewhere and then back again.  These are caused 

by the order of entries in the raw data log and do not reflect “true” 

changes to the point data. 



Adjusting Prism-Rod Height Post-Survey in ForeSight 2.2.5 
This secion describes how to adjust the stored Prism-Rod height for a series of points collected in a 

survey. This process involves editing the .raw file and regenerating the coordinates (.job file).   

Background 

The total station produces two files during the course of a survey: a .raw and .job file.  The .raw file 

contains a log of the actions performed on the instrument, including adjusting the settings (rod height, 

instrument height, bearing, etc.), moving the total station to a new point, and taking a point (recorded 

as a distance, azimuth, and bearing). The .job file is crated from this log by converting the raw 

measurements into actual coordinates. 

During the course of data processing, you may discover a series of points that seem higher (or lower) in 

elevation than they should be (i.e. relative to nearby points). This is often the result of forgetting to 

change the prism-rod height setting on the total station when the rod height is changed. Fortunately, 

this is a problem that can be easily fixed in ForeSight. 

Steps 

1. Make a note of the Points (ID number) that need to be edited. This will be a single point or a 

series of sequential points. 

2. Click the Raw Data View button  (or Press “CTRL + 5”). 

 

3. The raw data view opens the .raw file and displays a log of the actions performed on the total 

station during the survey in sequential order.  

 
Figure 15. 

We are interested in rows labeled “HI/HR” (record of change in instrument or rod height) or “Sd 

Shot ##-##” (point collected). 

 



4. Look through the log file to find the series of points that you need to change. These will be 

labeled “Sd Shot [Point occupied by instrument]-[Point collected]”. 

 
Figure 16. 

For this example we will use points77-79. 

 

5. Move up the list until you find the “HI/HR” row that precedes the series of points you wish to 

adjust.  This will be the recorded instrument and rod heights used for each of the points that 

followed, until the instrument or rod height was changed (i.e. the next HI/HR entry). 

 
Figure 17. 

 

6. Double Click anywhere on the row to open a Raw Data input dialog and change to the correct 

value.  

 
Figure 18. 

Click Store to make the change. 



 
Figure 19. 

7. If you need to make a change to the instrument/rod height within a sequence of points, 

highlight the line above the position you want to make the change. 

 
Figure 20. - In this example, we want to make a rod-height change to point70-76. Line 117 (Point 

1-69) is highlighted. 

Click Insert Line(s) (Select line below which you want to insert) on the Edit Menu. 

 
Figure 21. 

On the Insert Raw Data window, select the HiHr Tab and enter an instrument and rod height 

(must enter both values). Click Store, then close the window (or click cancel). 

 
Figure 22. 



The line is added to the raw file. 

    
Figure 23. 

 

8. When you have completed the changes to the raw file, you need to regenerate the coordinates 

(.job file). Select Generate Coordinates from Raw Data in the Tools Menu. 

  
Figure 24. 

9. Set Change elevations only to Checked and Change Descriptions to Unchecked.

 
Figure 25. 

 



10. Click View Report to verify your changes. Then click OK to close the Report viewer. 

 
Figure 26. 

11. If you are satisfied with the changes, click Generate to make the changes to the .job file. 


